blog.atwork.at

news and infos about microsoft, technology, cloud and more

Exchange 2013 DAG Anlage schlägt fehl

Wer hat sich schon mal so richtig auf ein Exchange 2013 Setup gefreut um dann festzustellen, dass beim Anlegen der Database Availability Group ein sehr kryptischen Fehler folgt?

image

“Sie müssen für diese Eigenschaft einen Wert angeben.”

JA – es ist ein deutscher Server, das war ned ich, ich schwörs! Konzentriert euch aufs Thema!

Also – Der Fehler ist schonmal seltsam, man fangt an zu suchen und schaut ins DAG Creation Log.
Für jeden DAG Task gibts ein Log, welches in C:\ExchangeSetupLog\DagTasks zu finden ist.

new-databaseavailabiltygroup started on machine EXCSRV01.
[2013-09-17T16:45:22] new-dag started
[2013-09-17T16:45:22] commandline:         $scriptCmd = {& $wrappedCmd @PSBoundParameters }

[2013-09-17T16:45:22] Option 'Name' = ''.
[2013-09-17T16:45:22] Option 'WitnessServer' = 'rdpsrv01'.
[2013-09-17T16:45:22] Option 'WitnessDirectory' = 'c:\dag01_witness'.
[2013-09-17T16:45:22] Option 'WhatIf' = ''.

Schaut irgendwie seltsam aus. Man würde meinen, der Fehler bezieht sich auf genau diesen “NAME” der offensichtlich nicht übernommen wird.
So probiert man weiter mit unterschiedlichen Werten rum und stellt fest: Nimmt man nicht “DAG01” sondern “DAG1” geht's! Allerdings bricht die Ausfürhung dann mit einem anderen Fehler ab:

image

“Der vollqualifizierte Domänenname für ‘DAG01’ konnte nicht gefunden werden”.

Man wundert sich hin und her und sucht aber irgendwie findet sich nix. Aber.. warum vollqualifizierter Domänname,.. FQDN.
Hmm.. Im DNS steht der Host nicht, aber im Hintergrund wir doch ein Computerobject für den Cluster Virtual Name angelegt.

image

Man sieht, ich hätt da jetzt scho a bissl rumprobiert. Wenn man dann weiter schaut

image

gibts dort auch keinen dnsHostName im Gegensatz zu vielen anderen Computeraccounts wo dieses Attribute befüllt ist.
Seltsam? Richtig. Das Problem dürfte sein, die Gruppe “Exchange Trusted SubSystem” legt diesen Account an und verwaltet ihn. Wenn die Gruppe aber nicht Full Access auf den ComputerAccount hat, dann kann sie ihn auch nicht verwalten.

Ich gebe also Full Access der “Exchange Trusted SubSystem” Gruppe und schon:

image

Ja ok, das Computerkonto muss deaktiviert werden. Nächster Versuch:

image

Ja, korrekt, das kommt, wenn man zu ungeduldig ist. Kurz warten bis die Replic gegriffen hat, und schon klappts auch mit dem DAG Cluster. Winking smile

Für alle gepeinigten Exchange 2013 DAG Cluster Installateure.

LG Christoph

Comments (1) -

  • Q*

    2/18/2014 3:27:50 PM |

    super endlich mal Hilfe zu dem unfug!
    Danke sehr!

Loading