blog.atwork.at

news and infos about microsoft, technology, cloud and more

Importing a VM from Hyper-V 2008 R2 to Hyper-V 2012 R2

During the holidays I stumbled about Hyper-V and importing an exported virtual machine from Hyper-V 2008 R2 to Hyper-V 2012. Well, of course, exporting, copying the files onto the new host machine and importing. Sounds easy - and how it´s supposed to work - but the Hyper-V 2012 says "There´s no spoon virtual machine to import"!

image

The Import Wizard error message says:
"Hyper-V did not find virtual machines to import from location "<path>"."

Glad that I found a great article about this problem by Rhoderick Milne [MSFT] on TechNet!

Windows Hyper-V 2012 & 8.1 Hyper-V Did Not Find Virtual Machine to Import

The article is really worth to be read! Here´s a short conclusion about the main topics in there:

So, my (simple) solution was: My original Hyper-V 2008 host is still available. Shut down the VM so that it´s stopped and go to the folder where the virtual machine configuration files are stored. In my case this is C:\VPC\Virtual Machines.

Locate the (last) VM configuration file, check if it´s the right one (here work16).

image

Once you´re sure it´s the right file, copy the file (here "79E8CB8E-6B7F-429B-B70C-8AD0E807435D.xml") to the new Hyper-V 2012 machine. I copied it to the same directory of the exported VM.

image

Now, import the VM with the path where the config file is stored.

image

And - tataaa - now it works!

image

The rest behaves as expected... reuse the existing VM-ID, locate the existing VHDs (D:\VPC\work16\Virtual Hard Disks\), connect the NIC and so on.

image

When done, the import action should be look like this summary.

image

That´s it. Happy importing (again)! Zwinkerndes Smiley

Comments (3) -

  • rinz

    3/17/2014 5:13:33 PM |

    Somewhat ridiculous... exported 2008 vm can be imported in 2012, but not in 2012 R2. What is MS thinking?

  • Octo

    8/11/2015 11:41:44 PM |

    Works! Thanks a mill Smile

  • Jules

    2/5/2016 6:43:44 PM |

    Thank you sir, that did the trick, worked perfectly.

Loading